1025 PAT Ranking (25 分)

2021/9/11 6:07:45

本文主要是介绍1025 PAT Ranking (25 分),对大家解决编程问题具有一定的参考价值,需要的程序猿们随着小编来一起学习吧!

1025 PAT Ranking (25 分)

Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (≤100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (≤300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

registration_number final_rank location_number local_rank

The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.

Sample Input:

2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85结尾无空行

Sample Output:

9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4
结尾无空行

解释

输入考场数N,然后输入N个考场信息,分别是先输入人数K,接下来K行输入考生考号和得分

输出:

总考生数

考号 总排名 考场号 考场内的排名

注意并列排名的情况

#include<iostream>
#include<algorithm>
#include<string>
#include<string.h>
using namespace std;
//定义结构体,存储学生信息
typedef struct people{
    string ID;
    int grade;
    int location_number;
    int local_rank;
    int final_rank;
}pe;
pe p[4000];
pe rd_p[4000];
bool cmp(pe a,pe b)
{//成绩相同,学号升序排列
    if(a.grade!=b.grade)
        return a.grade>b.grade;
    else
        return strcmp(a.ID.data(),b.ID.data())<0;
}
int main()
{
    int N,M=0;
    //考场数
    cin>>N;
    for(int i=1;i<=N;i++)
    {
        int m;
        cin>>m;
        M+=m;//总人数
        //在当地的排名
        for(int j=0;j<m;j++)
        {
            //输入考号,成绩
            cin>>rd_p[j].ID>>rd_p[j].grade;
            //考场号
            rd_p[j].location_number=i;
        }
        //考场内排名
        sort(rd_p,rd_p+m,cmp);
        rd_p[0].local_rank=1;
        
        for(int k=1;k<m;k++)
        {
            //有并列
            if(rd_p[k].grade==rd_p[k-1].grade)
                rd_p[k].local_rank=rd_p[k-1].local_rank;
            else//没有并列
                rd_p[k].local_rank=k+1;
        }
        for(int k=0;k<m;k++)//赋值给总数组
            p[k+M-m]=rd_p[k];
    }
    //总排名
    sort(p,p+M,cmp);
    p[0].final_rank=1;
    for(int k=1;k<M;k++)
    {
        //有并列
        if(p[k].grade==p[k-1].grade)
            p[k].final_rank=p[k-1].final_rank;
        //没有并列
        else
            p[k].final_rank=k+1;
    }
    cout<<M<<endl;
    for(int k=0;k<M;k++)
        cout<<p[k].ID<<" "<<p[k].final_rank<<" "<<p[k].location_number<<" "<<p[k].local_rank<<endl;
    return 0;
}


这篇关于1025 PAT Ranking (25 分)的文章就介绍到这儿,希望我们推荐的文章对大家有所帮助,也希望大家多多支持为之网!


扫一扫关注最新编程教程