1010 Radix (25 分)(二分)【回顾】

2021/12/3 23:16:53

本文主要是介绍1010 Radix (25 分)(二分)【回顾】,对大家解决编程问题具有一定的参考价值,需要的程序猿们随着小编来一起学习吧!

Given a pair of positive integers, for example, 6 and 110, can this equation 6 = 110 be true? The answer is "yes", if 6 is a decimal number and 110 is a binary number.

Now for any pair of positive integers N1 and N2, your task is to find the radix of one number while that of the other is given.

Input Specification:

Each input file contains one test case. Each case occupies a line which contains 4 positive integers:
N1 N2 tag radix
Here N1 and N2 each has no more than 10 digits. A digit is less than its radix and is chosen from the set {0-9, a-z} where 0-9 represent the decimal numbers 0-9, and a-z represent the decimal numbers 10-35. The last number "radix" is the radix of N1 if "tag" is 1, or of N2 if "tag" is 2.

Output Specification:

For each test case, print in one line the radix of the other number so that the equation N1 = N2 is true. If the equation is impossible, print "Impossible". If the solution is not unique, output the smallest possible radix.

Sample Input 1:

6 110 1 10

Sample Output 1:

2

Sample Input 2:

1 ab 1 2

Sample Output 2:

Impossible

生词

英文 解释
radix 进制

分析:

convert函数:给定一个数值和一个进制,将它转化为10进制。转化过程中可能产生溢出

find_radix函数:找到令两个数值相等的进制数。在查找的过程中,需要使用二分查找算法,如果使用当前进制转化得到数值比另一个大或者小于0,说明这个进制太大~

原文链接:https://blog.csdn.net/liuchuo/article/details/52495925

题解

image

#include <bits/stdc++.h>

using namespace std;
typedef long long ll;
ll Map[256];
ll inf=(1ll<<63)-1;
char n1[20],n2[20],temp[20];
int tag,radix;
void init()
{
    for(char c='0';c<='9';c++){
        Map[c]=c-'0';
    }
    for(char c='a';c<='z';c++){
        Map[c]=c-'a'+10;
    }
}
ll convertNum10(char a[],ll radix,ll t){
    ll ans=0;
    int len=strlen(a);
    for(int i=0;i<len;i++){
        ans=ans*radix+Map[a[i]];
        if(ans<0||ans>t) return -1;
    }
    return ans;
}
int findLargestDigit(char n2[]){
    int ans=-1,len=strlen(n2);
    for(int i=0;i<len;i++){
        if(Map[n2[i]]>ans){
            ans=Map[n2[i]];
        }
    }
    return ans+1;
}
int cmp(char n2[],ll radix,ll t){
    int len=strlen(n2);
    ll num=convertNum10(n2,radix,t);
    if(num<0) return 1;
    if(t>num) return -1;
    else if(t==num) return 0;
    else return 1;
}
ll binarySearch(char n2[],ll left,ll right,ll t)
{
    ll mid;
    while(left<=right){
        mid=(left+right)/2;
        int flag=cmp(n2,mid,t);
        if(flag==0) return mid;
        else if(flag==-1) left=mid+1;
        else right=mid-1;
    }
    return -1;
}
int main()
{
#ifdef ONLINE_JUDGE
#else
    freopen("1.txt", "r", stdin);
#endif
    init();
    scanf("%s %s %d %d",n1,n2,&tag,&radix);
    if(tag==2) swap(n1,n2);
    ll t=convertNum10(n1,radix,inf);
    ll low=findLargestDigit(n2);
    ll high=max(low,t)+1;
    ll ans=binarySearch(n2,low,high,t);
    if(ans==-1) printf("Impossible\n");
    else printf("%lld\n",ans);
    return 0;
}

详解版题解

image
image
image



这篇关于1010 Radix (25 分)(二分)【回顾】的文章就介绍到这儿,希望我们推荐的文章对大家有所帮助,也希望大家多多支持为之网!


扫一扫关注最新编程教程