C++翻译A1042 Shuffling题解

2022/1/17 12:03:38

本文主要是介绍C++翻译A1042 Shuffling题解,对大家解决编程问题具有一定的参考价值,需要的程序猿们随着小编来一起学习吧!

英文长度很长,有点不想翻译,但是马上就要考试了,所以还是自己翻译吧。

Shuffling is a procedure used to randomize a deck of playing cards.

洗牌是一道程序常用于随机玩牌,

词汇积累:casinos 赌场

Because standard shuffling techniques are seen as weak, and in order to avoid “inside jobs” where employees collaborate with gamblers by performing inadequate shuffles, many casinos employ automatic shuffling machines. Your task is to simulate a shuffling machine.

因为标准洗牌技术看起来是一种缺陷,并且目的避免内部工作,雇佣人员合作赌博者执行不充足洗牌.许多赌场雇佣自动洗牌及其,你的任务是模拟一个洗牌机器。

The machine shuffles a deck of 54 cards according to a given random order and repeats for a given number of times. It is assumed that the initial status of a card deck is in the following order:

机器洗54张卡组,根据跟定的任意序列以及重复的给定次数的数字,推测一个初步的下列的卡牌顺序。

S1, S2, ..., S13, 
H1, H2, ..., H13, 
C1, C2, ..., C13, 
D1, D2, ..., D13, 
J1, J2

where “S” stands for “Spade”, “H” for “Heart”, “C” for “Club”, “D” for “Diamond”, and “J” for “Joker”. A given order is a permutation of distinct integers in [1, 54]. If the number at the i-th position is j, it means to move the card from position i to position j. For example, suppose we only have 5 cards: S3, H5, C1, D13 and J2. Given a shuffling order {4, 2, 5, 3, 1}, the result will be: J2, H5, D13, S3, C1. If we are to repeat the shuffling again, the result will be: C1, H5, S3, J2, D13.

S代表了 蜘蛛 ,H代表红桃,C代表俱乐部,J代表节课,给定的序列是一个无重复的54个数字范围的序列,如果数字在第i位置是j,意味着移动数字从i到j,举个例子,假设我们只有五个卡片,S3,H5,C1,D13和J2,给定一个洗牌顺序[[4,2,5,3,1],结果将会是[J2,H5,D13,S3,C1],如果我们重复这个洗牌顺序,这个结果1将会是C1,H5,S3,J2,D13

Input Specification:

输入规格

Each input file contains one test case. For each case, the first line contains a positive integer K (≤20) which is the number of repeat times. Then the next line contains the given order. All the numbers in a line are separated by a space.

每个输入文件包含一个测试样例,针对每个样例,第一行包含正整数K<20,它是一个重复的数字,然后我们接下来一行包含给定的数列,所有的数字在一行,由空格隔开.

Output Specification:

输出规格

For each test case, print the shuffling results in one line. All the cards are separated by a space, and there must be no extra space at the end of the line.

输出规格,针对1每个测试样例,我们答应洗牌结果,在一行,所有的派,有空格隔开,而且必须行尾没有空格。

Sample Input:

2
36 52 37 38 3 39 40 53 54 41 11 12 13 42 43 44 2 4 23 24 25 26 27 6 7 8 48 49 50 51 9 10 14 15 16 5 17 18 19 1 20 21 22 28 29 30 31 32 33 34 35 45 46 47

Sample Output:

S7 C11 C10 C12 S1 H7 H8 H9 D8 D9 S11 S12 S13 D10 D11 D12 S3 S4 S6 S10 H1 H2 C13 D2 D3 D4 H6 H3 D13 J1 J2 C1 C2 C3 C4 D1 S5 H5 H11 H12 C6 C7 C8 C9 S2 S8 S9 H10 D5 D6 D7 H4 H13 C5

核心思路

不会stl库,不会存储这五十二张牌,还有就是取模不是很熟练,我竟然想不到取模这种运算,两个数组想到了,但是1没有想到转化为代码,先将数据倒到temp里,然后用temp倒回s里就行了。

完整代码方法1

#include<iostream>
using namespace std;
int main()
{
    int i,j,k,l;
    string s[54];
    for(int i = 0;i<52;i++){
        j = i/13;
        if(j==0) s[i]+='S';
        else if(j==1) s[i]+='H';
        else if(j==2) s[i]+='C';
        else s[i]+= 'D';
        s[i]+= to_string(i%13+1);
    }

    s[52]="J1";
    s[53] = "J2";
    //初始化
    int K,gowhere[54];
    cin >>K;
    for(i=0;i<54;i++){
        cin >> gowhere[i];
    }//输入
    while(K--){
        string temp[54];
        for(i=0;i<54;i++){
            temp[gowhere[i]-1] = s[i];
        }
        for(i=0;i<54;i++)
            s[i] = temp[i];
    }
    for(i=0;i<54;i++){
        if(i) cout << " ";
        cout << s[i];
    }
}

测试效果

在这里插入图片描述



这篇关于C++翻译A1042 Shuffling题解的文章就介绍到这儿,希望我们推荐的文章对大家有所帮助,也希望大家多多支持为之网!


扫一扫关注最新编程教程