PAT Advanced 1032 Sharing(25)

2022/9/6 23:25:48

本文主要是介绍PAT Advanced 1032 Sharing(25),对大家解决编程问题具有一定的参考价值,需要的程序猿们随着小编来一起学习吧!

题目描述:

To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, loading and being are stored as showed in Figure 1.

image

You are supposed to find the starting position of the common suffix (e.g. the position of i in Figure 1).
Input Specification:

Each input file contains one test case. For each case, the first line contains two addresses of nodes and a positive N (≤105), where the two addresses are the addresses of the first nodes of the two words, and N is the total number of nodes. The address of a node is a 5-digit positive integer, and NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is the letter contained by this node which is an English letter chosen from { a-z, A-Z }, and Next is the position of the next node.
Output Specification:

For each case, simply output the 5-digit starting position of the common suffix. If the two words have no common suffix, output -1 instead.

Sample Input 1:

11111 22222 9
67890 i 00002
00010 a 12345
00003 g -1
12345 D 67890
00002 n 00003
22222 B 23456
11111 L 00001
23456 e 67890
00001 o 00010

Sample Output 1:

67890

Sample Input 2:

00001 00002 4
00001 a 10001
10001 s -1
00002 a 10002
10002 t -1

Sample Output 2:

-1

算法描述:链表 结构体

题目大意:

求两个链表的首个共同结点的地址。如果没有,就输出-1

#include<iostream>
#include<vector>
using namespace std;

struct node{ // 静态链表  不需要指针
    char data;
    int next;
};
node no[100010];

int main()
{
    int h1, h2, n, addr, i, j;
    cin >> h1 >> h2 >> n;
    
    while(n --)
    {
        cin >> addr;
        cin >> no[addr].data >> no[addr].next;
    }
    
    vector<int> v1, v2;
    for(i = h1 ; i != -1 ; i = no[i].next)
        v1.push_back(i);

    for(i = h2 ; i != -1 ; i = no[i].next)
        v2.push_back(i);
    // 从后往前遍历两链表,直至两链表元素不同
    for(i = v1.size() - 1, j = v2.size() - 1 ; i >= 0 && j >= 0 && v1[i] == v2[j] ; i --, j --);
    // 没有共同后缀
    if(i == v1.size() - 1)    cout << -1;
    else    printf("%05d", v1[i + 1]);
    return 0;
}


这篇关于PAT Advanced 1032 Sharing(25)的文章就介绍到这儿,希望我们推荐的文章对大家有所帮助,也希望大家多多支持为之网!


扫一扫关注最新编程教程